httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yaron Ruckenstein <yaron.ruckenst...@mobilitec.com>
Subject [users@httpd] Problem building Apache with OpenSSL
Date Mon, 09 May 2005 07:37:05 GMT
Hi,

I'm trying to build Apache  2.0.54 with openssl 0.9.7g

I'm running on "Red Hat Enterprise Linux AS release 3 (Taroon)"

I built OpenSSL using the following commands:
#./config threads shared -D_REENTRANT --openssldir=/home/inst/openssl
#make
#make install

Then I tried to build apache with the following commands:
#CC="gcc" ./configure  --prefix=/home/inst/apache --enable-mods-shared=all \
 --disable-auth_digest --enable-ssl  --with-ssl=/home/inst/openssl
--with-port=7009 \
 --disable-example
#make

The make fails in the srclib/pcre directory saying:
./dftables: error while loading shared libraries: libssl.so.0.9.7: cannot
open shared  \
object file: No such file or directory

In the invoked command I see '-L/home/inst/openssl/lib' and '-lssl'
And the file /home/inst/openssl/lib/libssl.so.0.9.7 looks OK.
(The commands 'file' or 'nm' on the file show relevant data) 

Once the build is done, it is to be packed and be install as part of our
product,
(The install dir is changed according to the install needs)

Thanks a lot,
Yaron.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message