httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gibson, Rob" <Rob.Gib...@softwareagusa.com>
Subject [users@httpd] 403 on XP accessing an XML database document
Date Wed, 18 May 2005 18:13:02 GMT
Environment: Windows XP Office with SP2
And          Windows 2000 Professional
Both have Apache 2.0.54 installed.  Tested earlier with 2.0.48

In Apache I use the LoadModule directive so that I get access to an XML
database.
And I use the Location directive to define the access used for the
database calls.  Each box has its own copy of the XML database.  So the
calls are to a locally running database, nothing is on a remote system.

Example:
LoadModule  ino_module modules/Apache2ModuleIno.dll

<Location /tamino>
SetHandler ino
Order allow,deny
Allow from all
</Location>

So far so good.  I could query the database and retrieve the XML
documents.  This worked fine with both Windows 2000P and XP.

Then my IS department updated the XP machine with SP2 and every update
for XP they could find.

Since then, on the XP box, I can no longer access the documents in the
XML database.
I can query the database okay, i.e., how many docs are loaded, how many
docs contain this value, things like that.

But when I try to retrieve a specific document I receive the error:

Forbidden
You don't have permission to access
/tamino/SCS/SWAPDocs/Processes/SWAP/.../support/Processes/Corporate
Disaster Recovery Plan.doc on this server.
________________________________________
Apache/2.0.54 (Win32) Server at XP-machine Name Port 80

The Apache Access.log shows:
(The IP address) [18/May/2005:10:59:52 -0600] "GET
/tamino/SCS/SWAPDocs/Processes/SWAP/.../support/Processes/Corporate
Disaster Recovery Plan.doc HTTP/1.1" 403 404

There is nothing noted in the Apache Error.log

I have set the LogLevel to debug in Apache but this does not provide any
additional information.

I have disable and/or turned off everything that I can think of as far
as Windows security on XP goes.
- The firewall has been disabled
- Every zone has been set to the lowest level possible.
- I have manually set, in the Internet options, to allow everything.
Either it is allow or is set to prompt.
- I have tested this with IE and Mozilla Firefox.  There is no
difference.

McAfee is installed on this (XP) machine.  I have disabled it also to no
avail.

My first thought was this is a problem introduced by SP2 for XP.  But
there is no information in the system event logs.  Plus I have disabled
all the security features that I can find.

>From the error noted above you can see that the file name in the
database was stored to resemble the directory path where it original
came from. This file name includes the "/.../" syntax.  Thinking this
may be the problem, I have tried to modify this (the "...") to use the
backslash ("\") character so this is not interrupted as something else
(wildcard or something) but it didn't help. 

I have tried to retrieve the document directly using the URL address in
my web browser and by using an application that uses an API for Jscript
that can access the XML database.

It seems that the LoadModule directive is not taking place when I am
requesting the document on XP.  If it were, it would not be trying to
find this file on disk.  At least, to me, that is what it appears to be
doing from the error message.

But, if this is true, why did this work before SP2 was installed?  And
why does it continue to work on Windows 2000?

One final note:  I retested this on the XP box using IIS and it works
correctly, without any error, but I can't explain why.  And I would
prefer to not use IIS if it is possible. 

Anyone know how to correct this problem?

Thank you in advance,
Rob


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message