httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Patterson" <patterson...@earthlink.net>
Subject Re: [users@httpd] Virtual Hosts on WinXP Pro Apache 2.0.54
Date Thu, 05 May 2005 12:56:52 GMT
I did it a little different, but just finished setting up several domains on 
WinXP Pro Apache 2.0.54.  Probably some of conf file could be simplified, 
but everything does work.

My Apache is set up in c:\apache\Apache2\.

The domains are set up in C:\apache\Apache2\Websites\, with the website 
roots at c:\apache\Apache2\Websites\name\www\

In my configeration file, I have the following"

<VirtualHost *:80>
    DocumentRoot "C:/apache/Apache2/Websites/Tompatterson/www"
    ServerName tompatterson.dnsalias.com
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/apache/Apache2/Websites/Tompatterson/www"
    ServerName www.tompatterson.dnsalias.com
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/apache/Apache2/Websites/Depression/www"
    ServerName depressionanonymous.tzo.com
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/apache/Apache2/Websites/Depression/www"
    ServerName www.depressionanonymous.tzo.com
</VirtualHost>

The reason I set up two for each site was that I needed it to be able to 
find each site with both http://domainname and with http://www.domainname. 
I guess maybe I should have used the aliases to avoid having two entries for 
each site.

-Tom

----- Original Message ----- 
From: "Joshua Slive" <jslive@gmail.com>
To: <users@httpd.apache.org>; "Gary" <gary.peake@comcast.net>
Sent: Thursday, May 05, 2005 7:21 AM
Subject: Re: [users@httpd] Virtual Hosts on WinXP Pro Apache 2.0.54


On 5/5/05, Gary <gary.peake@comcast.net> wrote:
> I have tried every combination I can find for VirtualHost on apache 2.0.54
> and Windows XP.
>
> I have two name based domains: domain1.com and domain2.info
>
> Can someone be so kind as to give me a secure setup that will work?
>
> Everything goes into C:/apache2/httdocs on my test server at 127.0.0.1.

The configuration listed here:
http://httpd.apache.org/docs-2.0/vhosts/name-based.html#using
is secure and works.

If you need more help, you'll need to be much more specific about what
you tried and what the result was.

Joshua.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message