httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] suEXEC documentation lacking? No mention of mod_suexec
Date Wed, 27 Apr 2005 15:05:57 GMT
On 4/26/05, Mark H. Wood <mwood@iupui.edu> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Am I missing something, or is there no mention whatsoever of mod_suexec in
> either "Suexec Execution for CGI" or "CGI: Dynamic Content"?  I spent some
> considerable time staring at a setup that seemed correct but never logged
> the "suEXEC mechanism enabled" message, until I recalled seeing a
> mod_suexec somewhere.  I added a LoadModule directive for it and now it's
> logging that it found suexec2.
> 
> Shouldn't both of those manual entries say something to the effect that
> "you should ensure that mod_suexec is loaded"?
> 
> This is on Apache httpd 2.0.52 from the latest Gentoo ebuild.

Yes, mod_suexec should be mentioned more explicitly.

But it does mention the need to compile with --enable-suexec, which
should get you mod_suexec.  And it does talk about the SuexecUserGroup
directive, which is provided by mod_suexec.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message