httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] index.htm recognized in virtual host, but not index.html
Date Tue, 19 Apr 2005 17:34:39 GMT
On 19 Apr 2005 20:28:06 +0300, Florin <florin_gf@yahoo.fr> wrote:
> Hello world! :)
> After a long time (I didn't have enough time to test/change
> configuration things), I come back with my problem.
> Joshua, unfortunately I was forced to use different NameVirtualHost/
> <Virtualhost> with names instead of IP address. This is because I use
> different vhost names on a server with only one IP address and want to
> have different log files. Besides, the reverse addressing resolution is
> not unique; so I cannot use IP in NameVirtualHost/ <Virtualhost>.

Use
NameVirtualHost *:80
<VirtualHost *:80>
ServerName host1.example.com
etc...
</VirtualHost>
<VirtualHost *:80>
ServerName host2.example.com
etc...
</VirtualHost>
and so on.  This is the example given in the docs.

Your problem sounds to me very much like some complicated interaction
between funky DNS and caching of your responses at the browser.  So
you should start by having an apache configuration that is not
DNS-dependent.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message