httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] Problem starting apache-2.0.53 on Solaris 5.8
Date Sat, 16 Apr 2005 16:41:18 GMT
On 4/15/05, Andrew Afliatunov <andy@taom.ru> wrote:
> I tried to start server with '/usr/local/apache2/bin/httpd -X -k start',
> - the result was the same - no debugging info, no log.
> Then I tried to envestigate problem with 'truss
> /usr/local/apache2/bin/httpd -X -k start', - it's output says that httpd
> successfully opens all necessary libraries and then hangs with this:
> --
> lwp_sema_wait(0x00093FD8)       (sleeping...)
> signotifywait()                 (sleeping...)
> door_return(0x00000000, 0, 0x00000000, 0) (sleeping...)
> lwp_cond_wait(0xFEEF55B0, 0xFEEF55C0, 0xFEE93C48) (sleeping...)
> --
> Would you, please, give me advice how to make it work?

Just guesses:

- Use the AcceptMutex directive to choose another locking directive.

- Run under gdb and get a backtrace when it gets stuck.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message