httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Donker <l...@webpagina.nu>
Subject [users@httpd] make dies on 2.0.54
Date Wed, 27 Apr 2005 14:47:35 GMT
I'm trying to install Apache 2.0.54 on Debian sarge with the following 
configure line:

./configure --enable-auth-dbm --enable-auth-ldap --enable-dav 
--enable-dav-fs --enable-deflate --enable-headers --enable-info 
--enable-ldap --enable-mime-magic --enable-proxy --enable-proxy-connect 
--enable-proxy-ftp--enable-proxy-http --enable-rewrite --enable-so 
--enable-speling --enable-ssl --enable-unique-id --enable-usertrack 
--enable-vhost-alias --with-mpm=prefork --enable-modules=all --with-apxs 
--with-ldap --with-authldap  

Configure ends wel, but make dies telling me:

make[1]: Entering directory `/root/httpd-2.0.54'
/root/httpd-2.0.54/srclib/apr/libtool --silent --mode=compile gcc  -g 
-O2 -pthread    -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE 
-D_SVID_SOURCE -D_GNU_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER   
-I/root/httpd-2.0.54/srclib/apr/include 
-I/root/httpd-2.0.54/srclib/apr-util/include -I. 
-I/root/httpd-2.0.54/os/unix -I/root/httpd-2.0.54/server/mpm/prefork 
-I/root/httpd-2.0.54/modules/http -I/root/httpd-2.0.54/modules/filters 
-I/root/httpd-2.0.54/modules/proxy -I/root/httpd-2.0.54/include 
-I/root/httpd-2.0.54/modules/generators -I/root/httpd-2.0.54/server 
-I/usr/include/openssl -I/root/httpd-2.0.54/modules/dav/main 
-prefer-non-pic -static -c modules.c && touch modules.lo
/root/httpd-2.0.54/srclib/apr/libtool --silent --mode=link gcc  -g -O2 
-pthread   -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE 
-D_SVID_SOURCE -D_GNU_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER   
-I/root/httpd-2.0.54/srclib/apr/include 
-I/root/httpd-2.0.54/srclib/apr-util/include -I. 
-I/root/httpd-2.0.54/os/unix -I/root/httpd-2.0.54/server/mpm/prefork 
-I/root/httpd-2.0.54/modules/http -I/root/httpd-2.0.54/modules/filters 
-I/root/httpd-2.0.54/modules/proxy -I/root/httpd-2.0.54/include 
-I/root/httpd-2.0.54/modules/generators -I/root/httpd-2.0.54/server 
-I/usr/include/openssl -I/root/httpd-2.0.54/modules/dav/main 
-export-dynamic    -o httpd  modules.lo  modules/aaa/mod_access.la 
modules/aaa/mod_auth.la modules/aaa/mod_auth_anon.la 
modules/aaa/mod_auth_dbm.la modules/aaa/mod_auth_digest.la 
modules/experimental/mod_ldap.la modules/experimental/mod_auth_ldap.la 
modules/filters/mod_ext_filter.la modules/filters/mod_include.la 
modules/filters/mod_deflate.la modules/loggers/mod_log_config.la 
modules/loggers/mod_log_forensic.la modules/metadata/mod_env.la 
modules/metadata/mod_mime_magic.la modules/metadata/mod_cern_meta.la 
modules/metadata/mod_expires.la modules/metadata/mod_headers.la 
modules/metadata/mod_usertrack.la modules/metadata/mod_unique_id.la 
modules/metadata/mod_setenvif.la modules/proxy/mod_proxy.la 
modules/proxy/mod_proxy_connect.la modules/proxy/mod_proxy_ftp.la 
modules/proxy/mod_proxy_http.la modules/ssl/mod_ssl.la 
modules/http/mod_http.la modules/http/mod_mime.la 
modules/dav/main/mod_dav.la modules/generators/mod_status.la 
modules/generators/mod_autoindex.la modules/generators/mod_asis.la 
modules/generators/mod_info.la modules/generators/mod_cgi.la 
modules/dav/fs/mod_dav_fs.la modules/mappers/mod_vhost_alias.la 
modules/mappers/mod_negotiation.la modules/mappers/mod_dir.la 
modules/mappers/mod_imap.la modules/mappers/mod_actions.la 
modules/mappers/mod_speling.la modules/mappers/mod_userdir.la 
modules/mappers/mod_alias.la modules/mappers/mod_rewrite.la 
modules/mappers/mod_so.la server/mpm/prefork/libprefork.la 
server/libmain.la os/unix/libos.la -lz -lssl -lcrypto 
/root/httpd-2.0.54/srclib/pcre/libpcre.la 
/root/httpd-2.0.54/srclib/apr-util/libaprutil-0.la -lldap -llber 
-ldb-4.2 -lexpat /root/httpd-2.0.54/srclib/apr/libapr-0.la -lrt -lm 
-lcrypt -lnsl -lpthread -ldl
modules/experimental/.libs/mod_ldap.a(util_ldap.o)(.text+0x2234): In 
function `util_ldap_post_config':
/root/httpd-2.0.54/modules/experimental/util_ldap.c:1448: warning: the 
use of `tmpnam' is dangerous, better use `mkstemp'
make[1]: Leaving directory `/root/httpd-2.0.54'

What can I do to make this work?
More detail? Just ask!

Thanks
Patrick


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message