httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Afliatunov <a...@taom.ru>
Subject Re: [users@httpd] Problem starting apache-2.0.53 on Solaris 5.8
Date Wed, 20 Apr 2005 08:24:30 GMT
I've done the following:

#> unset LD_LIBRARY_PATH
#> LDFLAGS="-L/usr/local/lib -L/usr/lib"
#> LDFLAGS="$LDFLAGS -R/usr/local/lib:/usr/lib"
#> CPPFLAGS="-I/usr/local/include -I/usr/include"
#> export LDFLAGS CPPFLAGS
(Besides, I've done 'crle -l /usr/local/ssl/lib:/usr/local/lib:/usr/lib' 
before.)
#> ./configure
#> make
#> make install

Nothing changed - 'apachectl start' hangs, no logs are written, no 
errors are displaied.
Don't know what to do...
Maybe this info is usefull:
#> ldd /usr/local/apache2/bin/httpd
libaprutil-0.so.0 => /usr/local/apache2/lib/libaprutil-0.so.0
libdb-4.0.so => /usr/local/lib/libdb-4.0.so
libexpat.so.0 => /usr/local/apache2/lib/libexpat.so.0
libiconv.so.2 => /usr/local/lib/libiconv.so.2
libapr-0.so.0 => /usr/local/apache2/lib/libapr-0.so.0
librt.so.1 => /usr/lib/librt.so.1
libm.so.1 => /usr/lib/libm.so.1
libsocket.so.1 => /usr/lib/libsocket.so.1
libnsl.so.1 => /usr/lib/libnsl.so.1
libresolv.so.2 => /usr/lib/libresolv.so.2
libpthread.so.1 => /usr/lib/libpthread.so.1
libdl.so.1 => /usr/lib/libdl.so.1
libc.so.1 => /usr/lib/libc.so.1
libgcc_s.so.1 => /usr/local/lib/libgcc_s.so.1
libaio.so.1 => /usr/lib/libaio.so.1
libmp.so.2 => /usr/lib/libmp.so.2
libthread.so.1 => /usr/lib/libthread.so.1
/usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1
(there are no 'unfound' libraries)...

Markus Mayer wrote:

>As so many others, you're using LD_LIBRARY_PATH.  Please read the posts at 
>http://www.sunmanagers.org/pipermail/sunmanagers/2002-May/014178.html and
>http://mail-archives.eu.apache.org/mod_mbox/httpd-users/200504.mbox/<200504011815.13545.mymaillists%40gmx.at>
>
>You will need to get rid of LD_LIBRARY_PATH, set your CPPFLAGS and LDFLAGS 
>correctly, then rebuild apache form the start.  Also, you are using a very 
>recent version of gcc which may cause some problems (I'm not saying it is).  
>Not even I use anything more recent than 3.3.2, and I like using "recent/new" 
>software.
>
>If all this still fails, come back to the list with as much information as 
>possible about what you've done, and we'll try to help you further.
>
>Markus
>
>On Monday 18 April 2005 13:50, Andrew Afliatunov wrote:
>  
>
>>Markus Mayer wrote:
>>    
>>
>>>Unfortunately you have not provided any information about your build
>>>environment.  Please do an "env" and provide the output.  Also, which
>>>compiler are you using?  Without such information, it's impossible to help
>>>you.
>>>      
>>>
>>#> uname -a
>>SunOS webdev 5.8 Generic_108528-01 sun4u sparc SUNW,Ultra-5_10
>>
>>#> env
>>MANPATH=/usr/share/man:/usr/local/man
>>TERM=xterm
>>SHELL=/usr/local/bin/bash
>>SSH_CLIENT=192.168.1.61 1723 22
>>SSH_TTY=/dev/pts/3
>>USER=admara
>>LD_LIBRARY_PATH=/usr/local/ssl/lib:/u01/app/openldap/lib:/usr/local/lib:/us
>>r/lib PAGER=less
>>MAIL=/var/mail//admara
>>PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/usr/ccs/bin:/usr/li
>>b:/usr/bin/nsr:/usr/sbin/nsr:/usr/local/scripts PWD=/home/admara/
>>EDITOR=joe
>>TZ=GMT+4
>>PS1=\[\033[40;1;32;1m\]webdev\[\033[40;37;m\][\[\033[40;37;1m\]/3\[\033[40;
>>37;m\]]\[\033[40;33;1m\]\w\[\033[40;36;1m\]#>\[\033[40;37;m\] SHLVL=1
>>HOME=/home/admara/
>>LESS=-M -r
>>LOGNAME=admara
>>SSH_CONNECTION=192.168.1.61 1723 192.168.1.38 22
>>_=/usr/bin/env
>>
>>I'm using GNU gcc-3.4.2, make 3.80.
>>
>>    
>>
>>>Also, please refer to other posts on this list related to building and
>>>running apache on Solaris.
>>>      
>>>
>>I searched archive, but found nothing similar...
>>
>>    
>>
>>>Markus
>>>
>>>On Monday 18 April 2005 07:44, Andrew Afliatunov wrote:
>>>      
>>>
>>>>Hello!
>>>>I want to install apache-2 on Solaris 5.8 for testing purposes. So I
>>>>configured httpd-2.0.53 without options, just './configure'. It went OK.
>>>>'make' and 'make install' ran without any problem either.
>>>>But when I try to start server with '/usr/local/apache2/bin/apachectl
>>>>start' it doesn't start, and command line doesn't return. No logs are
>>>>written, and I have to kill the process from another terminal window.
>>>>I tried to start server with '/usr/local/apache2/bin/httpd -X -k start',
>>>>- the result was the same - no debugging info, no log.
>>>>Then I tried to envestigate problem with 'truss
>>>>/usr/local/apache2/bin/httpd -X -k start', - it's output says that httpd
>>>>successfully opens all necessary libraries and then hangs with this:
>>>>--
>>>>lwp_sema_wait(0x00093FD8)       (sleeping...)
>>>>signotifywait()                 (sleeping...)
>>>>door_return(0x00000000, 0, 0x00000000, 0) (sleeping...)
>>>>lwp_cond_wait(0xFEEF55B0, 0xFEEF55C0, 0xFEE93C48) (sleeping...)
>>>>--
>>>>Would you, please, give me advice how to make it work?
>>>>
>>>>--
>>>>Andrew.
>>>>        
>>>>
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>  
>


-- 
? ?????????, ?????????? ????????
????????? ??????.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message