httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Muktheshwar Sharma <Muktheshwar.Sha...@three.co.uk>
Subject RE: [users@httpd] migration from Apache 1.3.x to Apache 2
Date Wed, 30 Mar 2005 08:50:46 GMT
Hi,

Thanks for your quick response. I found the following information from
Apache configuration file (httpd.conf).
<IfModule !mpm_winnt.c>
<IfModule !mpm_netware.c>
#
# If you wish httpd to run as a different user or group, you must run
# httpd as root initially and it will switch.
#
# User/Group: The name (or #number) of the user/group to run httpd as.
#  . On SCO (ODT 3) use "User nouser" and "Group nogroup".
#  . On HPUX you may not be able to use shared memory as nobody, and the
#    suggested workaround is to create a user www and use that user.
#  NOTE that some kernels refuse to setgid(Group) or semctl(IPC_SET)
#  when the value of (unsigned)Group is above 60000;
#  don't use Group #-1 on these systems!
#
User nobody
#Group #-1
Group nobody
</IfModule>
</IfModule>

As you suggested I have checked the following files
1. /etc/group
2. /etc/passwd
3./etc/shadow

I did not find the entries wwwrun and www in the above files.

Would it require having these in the above files? I am starting and stopping
the Apache server using root account only.

Regards,
Muktheshwar
4th Line Support - Product Integration, 3 
Tel: +91 - 80 - 28520408 Extn: 84158 
Mobile: +91-98 45 98 10 44 
http://www.three.co.uk/ 
 

-----Original Message-----
From: John [mailto:isofroni@cc.uoi.gr] 
Sent: 30 March 2005 08:20
To: Muktheshwar Sharma
Subject: Re: [users@httpd] migration from Apache 1.3.x to Apache 2


From: Muktheshwar Sharma <Muktheshwar.Sharma@three.co.uk>
To: "'users@httpd.apache.org'" <users@httpd.apache.org>
Date: Wednesday, March 30, 2005, 8:35:10 AM
Subject: [users@httpd] migration from Apache 1.3.x to Apache 2



  Wednesday, March 30, 2005, 8:35:10 AM, you wrote:

      
  
  
> Hi,
  
>  
  
> I am migrating from Apache 1.3.27 to Apache 2.0.x. I have one
> module that is compiled for Apache 1.3.x now I want to use the same
> module for Apache 2.
  
>  
  
> In my earlier version of apache code I have one statement
> "MM_permission (0600, ap_uname2id(DEFAULT_USER),
> ap_gname2id(DEFAULT_GROUP));"
  
> Now when I am compiling this with apxs utility I am getting the following
error
  
>  
  
> /home/mukthi//apache2/mod_xx.c:315: `DEFAULT_USER' undeclared (first use
in this function)
  
> /home/mukthi//apache2/mod_xx.c:315: (Each undeclared identifier is
reported only once
  
> /home/mukthi//apache2/mod_xx.c:315: for each function it appears in.)
  
> /home/mukthi//apache2/mod_xx.c:315: `DEFAULT_GROUP' undeclared (first use
in this function)
  
>  
  
> As I could not able to find how to use DEFAULT_USER and 
> DEFAULT_GROUP in Apache 2. Could anybody help me in this regard? 
  
>  
  
> Thanks and Regards,
  
> Muktheshwar
  
> 4th Line Support - Product Integration, 3 
>  Tel: +91 - 80 - 28520408 Extn: 84158 
>  Mobile: +91-98 45 98 10 44 
> http://www.three.co.uk/
  
>  
  
>  
  
  

> 
> ________________________________________________________________________

>  This e-mail message (including any attachment) is intended only for the
personal
>  use of the recipient(s) named above. This message is confidential and may
be
>  legally privileged.  If you are not an intended recipient, you may not
review, copy or
>  distribute this message. If you have received this communication in
error, please notify
>  us immediately by e-mail and delete the original message.

>  Any views or opinions expressed in this message are those of the author
only.
>  Furthermore, this message (including any attachment) does not create any
legally
>  binding rights or obligations whatsoever, which may only be created by
the exchange
>  of hard copy documents signed by a duly authorised representative of
Hutchison
>  3G UK Limited.
> 
> ________________________________________________________________________

    


hello

probably there is an issue with the user, group in the apache
configuration.
Did you check the /etc/group and /etc/passwd and /etc/shadow files
that contain wwwrun and www respectiviely?



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


________________________________________________________________________

This e-mail message (including any attachment) is intended only for the personal 
use of the recipient(s) named above. This message is confidential and may be 
legally privileged.  If you are not an intended recipient, you may not review, copy or 
distribute this message. If you have received this communication in error, please notify 
us immediately by e-mail and delete the original message.

Any views or opinions expressed in this message are those of the author only. 
Furthermore, this message (including any attachment) does not create any legally 
binding rights or obligations whatsoever, which may only be created by the exchange 
of hard copy documents signed by a duly authorised representative of Hutchison 
3G UK Limited.
________________________________________________________________________


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message