httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lucas, David" <David.Lu...@unh.edu>
Subject [users@httpd] Rewrite question
Date Wed, 09 Mar 2005 19:46:53 GMT
Hello,

I have a question about rewrite and ssl.

I have the following placed in the httpd.conf:

DocumentRoot "/var/www/html"

RewriteEngine on
RewriteCond %{REMOTE_ADDR} ^10\.10\.131\.[0-9]
RewriteRule (.*) /nec/index.html
RewriteCond %{REMOTE_ADDR} !10\.10\.131\.[0-9]
RewriteRule (.*) /index.html

This seems to be working properly.

Now, what doesn't seem to work is SSL.  I have this in the ssl.conf
file:

DocumentRoot "/var/www/html/secure"

RewriteEngine on
RewriteCond %{REMOTE_ADDR} ^10\.10\.131\.[0-9]
RewriteRule (.*) /nec/index.html
RewriteCond %{REMOTE_ADDR} !10\.10\.131\.[0-9]
RewriteRule (.*) /index.html

And it seems that it is not working.  I get the right page but it
doesn't fully load, like I don't get the pictures and such.  In the log
it says that it can't find the file but it is there and it loads the
index.html file.  What I need to do is to get this to look at the source
IP address and then you load a different page then the default web
server page based on that IP address.  If someone can point me in the
right direction that would greatly help me!!

Thanks!!

Dave

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message