httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noah <s...@onastick.net>
Subject Re: [users@httpd] Upgrading mod_ssl
Date Thu, 10 Mar 2005 21:22:51 GMT
On Thu, Mar 10, 2005 at 03:55:07PM -0500, Kaplan, Andrew H. wrote:

> The procedure I had in mind was to download the latest versions of the Apache,
> OpenSSL, MM, and Mod_SSL components 
> and subsequently install them over the existing programs. Is this the correct
> procedure to follow, or is there a better method?

I generally manange everythings with symlinks, which allows for easy
rollback. So, for instance if your current layout was:

/usr/local/apache
/usr/local/apache/conf
/usr/local/apache/htdocs

etc, etc.

Move /usr/local/apache to /usr/local/apache-previous (or $VERSION) and
symlink /usr/local/apache-previous to /usr/local/apache. Install the new
apache into /usr/local/apache-new (or $NEWVERSION). When you're ready to 
cut over, shut down apache, repoint the symlink, and start it back up.
You could also use something like graft
(http://www.gormand.com.au/peters/tools/graft/graft.html) or stow
(http://www.gnu.org/software/stow/) to manage this
for you, if you'd rather.

Installing over top is just a recipe for pain. =)

--n

-- 
<huey> dd of=/dev/fd0 if=/dev/flippy bs=1024
<huey> ^^^ Making Flippy Floppy


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message