httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean Mao" <m...@helix.nih.gov>
Subject [users@httpd] build mod_log_mysql problem
Date Thu, 31 Mar 2005 16:58:17 GMT
Hello all,

When I tried to install this module after made the necessary modification, I
run into some library problem. Someone please help me and any advise will be
really appreciated.

Command:

In the ...../modules/logger directory, I run

/usr/local/apache.maoj/bin/apxs -a -i -c -L/usr/local/mysql/lib/ -I/usr/loca
l/mysql/include/ -lmysqlclient_r -lz mod_log_mysql.c

and got following error:

/usr/local/apache.maoj//build/libtool --silent --mode=compile
gcc -prefer-pic  -DAP_HAVE_DESIGNATED_INITIALIZER -DLINUX=2 -D_REENTRANT -D_
XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -g -O2 -pthread
-I/usr/local/apache.maoj//include  -I/usr/local/apache.maoj//include   -I/us
r/local/apache.maoj//include  -I/usr/local/mysql/include/  -c -o
mod_log_mysql.lo mod_log_mysql.c && touch mod_log_mysql.slo
/usr/local/apache.maoj//build/libtool --silent --mode=link gcc -o
mod_log_mysql.la  -L/usr/local/mysql/lib/ -lmysqlclient_r -lz -rpath
/usr/local/apache.maoj//modules -module -avoid-version    mod_log_mysql.lo
/usr/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
apxs:Error: Command failed with rc=65536

However, the file libz.so.1 do exist and links to version libz.so.1.1.4 in
/usr/lib/. I also add the following line to the command just in case apxs
won't automatically look in /usr/lib/ :
-L/usr/lib/

but still got the same error.

Thank you inadvance for your help.

Jean


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message