httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Mangin" <jon.man...@comcast.net>
Subject Re: [users@httpd] Access_log shows incorrect remote host address
Date Thu, 17 Mar 2005 13:05:35 GMT
If you access the server through your router's WAN address
and have port forwarding turned on, the access_log will
always reflect the router's LAN address.



----- Original Message ----- 
From: "Greg Jeziorski" <greg@jeziorski.com>
To: <users@httpd.apache.org>
Sent: Thursday, March 17, 2005 12:27 AM
Subject: RE: [users@httpd] Access_log shows incorrect remote host address


> The request is coming from the outside, I agree with your "really weird"
> assessment.  The network topology is as follows:
>
>
> ----------DSL "MODEM" --------------->SMC Router ------>Switch --> 
> Webserver
>   Public
> IP--192.168.2.x-----192.168.2.y--192.168.1.x------------192.168.1.y
>
>
> The address being logged is 192.168.2.y  The SMC is an SMC7004ABR.  I'm
> beginning to think the router is misbehaving, but I don't think it has the
> capability to terminate and initiate a new session. I've never seen any 
> kind
> of proxy function in it.
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message