httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yannis Tsakiris" <gtsaki...@dolnet.gr>
Subject Re: [users@httpd] Strange Problem
Date Mon, 28 Mar 2005 15:05:12 GMT
> Would be good to know if you had memory problems at that time too, i was 
> running apache 2.0.53 on suse 9.2 and had memory leak problems even with 
> apache not using any special modules. When the system started to swap, the 
> server was not responding, and sometimes after some minutes the kernel 
> managed to kill httpd and the cycle could start again ... running fine 
> ..then memory leak ..then pache and system stuck again.
> I m running no apache 1.3.33 on the same server and system and i have no 
> more problems. The memory gets to 10 000 KB free and dont move from there 
> nor swap.
> Pascal

# free
             total       used       free     shared    buffers     cached
Mem:       1032240    1018808      13432          0     218684     553084
-/+ buffers/cache:     247040     785200
Swap:            0          0          0

This is the output I get from the free command. It looks always like this 
(about 10MB free), both when the server runs smoothly and when the server is 
crashing.

> > It sounds like you have a problem with your CPU getting hot and the box
> > just stops.

No, this is not the case. The computer is still up and running, the problem 
is in the application layer. I can still execute commands or even restart 
the apache server when this happens. If the CPU just stopped because of 
excessive temperature I should get a still screen with no keyboard or mouse 
response.

> When you sat the 'server' is not responding, do you mean the console -or-
> Apache? Bad or looping code can cause the CPU to react as you describe. It
> is unclear to me what you mean by 'not responding'...
> Pete

You are right.. maybe the term I used was inappropriate.
I mean that when you ask a page from the web server you will never have it 
(you'll get time out) and when you try to type and execute a command in the 
shell, it goes very very slow (you type a character and it appears with lots 
of seconds delay).

Yannis Tsakiris


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message