httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From g.l...@itcilo.org
Subject [users@httpd] apache mod_rewrite suddenly stop working
Date Thu, 03 Feb 2005 09:32:35 GMT
Hi all, 

I've various servers with SuSe9.0 professional, using apache as a 
front-end to various application servers like tomcat and zope + 
mod_rewrite. 
I discovered yesterday that, on one of my server, mod_rewrite does not 
seem to work any more. The rewrite-log is empty since one month now. 
Fortunately on this server I only use a few rewritten rules but I really 
have no idea on what happened and how to solve the problem, as this server 
have been in production for one year now with mod_rewrite working. 
The configuration is the following: 
- rewrite is in the modules loaded by apache (/etc/sysconfig/apache2) 
- the rewrite Engine in on. 

Here is part of what I put in /etc/apache2/my_conf/my.conf: 
RewriteEngine on 
RewriteLog /var/log/apache2/rewrite.log 
RewriteLogLevel 5 
RewriteRule   ^/english/actrav/?(.*)    /actrav/actrav-english/$1  [R] 
RewriteRule   ^/french/actrav/?(.*)    /actrav/actrav-french/$1  [R] 

Apache stop and start without any problem, it's just that nothing is being 
rewritten, access to the normally rewritten urls go directly to the 
error.log saying that the file can not be found 

Any help would be greatly indicated 

Regards 

Gaƫl

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message