httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kirk Cassady" <Kirk.Cass...@rci.rogers.com>
Subject [users@httpd] Make problem v1.3.33
Date Wed, 09 Feb 2005 19:02:13 GMT
I'm trying to build/install v1.3.33 on a Solaris box with the following details:
 
- Solaris 2.8 (patched)
- OLD Apache 1.3.31 shut down but not removed (default from OS install)
- perl 5.8.5
- make 3.80
- gcc 3.4.2
 
At the "make" step I get the following error:
 
# make
===> src
make[1]: Entering directory `/tmp/apache_1.3.33'
make[2]: Entering directory `/tmp/apache_1.3.33/src'
===> src/os/unix
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=280 -DUSE_EXPAT -I../../lib/expat-lite
-DNO_DL_NEEDED `../../apaci` os.c
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=280 -DUSE_EXPAT -I../../lib/expat-lite
-DNO_DL_NEEDED `../../apaci` os-inline.c
rm -f libos.a
ar cr libos.a os.o os-inline.o
make[3]: execvp: ar: Permission denied
make[3]: *** [libos.a] Error 127
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/tmp/apache_1.3.33/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/tmp/apache_1.3.33'
make: *** [build] Error 2

Do I need to remove the old Apache?
 
I've done the PREFIX thing and set to a path different than the existing Apache.
 
Any help would be appreciated.
 
Thx,
kirk
Mime
View raw message