httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Stoll <technow...@gmx.de>
Subject Re: [users@httpd] apache2 chrooted on Solaris
Date Wed, 16 Feb 2005 11:42:54 GMT
Markus Mayer schrieb:
> Thanks for the info.  I got further but don't find a solution to the next two 
> problems I've come across.  
> 
> The first one is when apache2 is started in the chroot as normal.  It fails 
> during the initialisation and preconfiguration stage when it's starting up.  
> I tried looking at what was happening using gdb and for what ever reason a 
> pile of libraries seem to not be found, although they are there.  
> 
> I tried later to use the -X argument for the httpd and it ran happily.  I 
> could make requests, and PHP4 seemed to work relatively well, but that's 
> where I came across my second problem.
> 
> For what ever reason, through PHP in the chrooted environment I'm not able to 
> open the socket to the MySQL server that's running on the same machine in a 
> normal environment.  I don't know what the solution to this is.

It lloks like you have NOT a sane chroot enviroment... remember, you cannot 
access a socket in /tmp when chrootet to /jail  - it has to be 
/jail/tmp/socketfile as an example...
Check the availability of the offending libraries as the chrootet user your 
running apache with, make a su and chroot to /jail and test it one by one.

If all is sane, a script which checks and compares this environment with 
global system files is extremely helpful when upgrading the system...

Best regards, AS

Mime
View raw message