httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] WebDAV problem
Date Mon, 24 Jan 2005 21:35:36 GMT
On Mon, 24 Jan 2005 13:58:58 -0600, Kevin Schroeder
<kschroeder@mirageworks.com> wrote:
> Hello,
>     I'm trying to put a file using the Apache WebDAV module.  I'm able to
> log in and download files but when I try to put the files I get a 403 error.
> My error log shows
> 
> [Mon Jan 24 13:40:18 2005] [error] [client .........] (20)Not a directory:
> User "  [403, #0]

> The source of the problem would seem to be
> 
> [pid 27904] open("/var/www/sites/whatYouNeed.html/.htaccess", O_RDONLY) = -1
> ENOTDIR (Not a directory)
> 
> since that's what shows up in the error log.  My .htaccess files that
> referenced here are all empty with the configuration done in httpd.conf.
> 
> Is this a bug, or am I simply doing something wrong?

Let me guess: you are using the Reiser filesystem?  Reiser has a
feature where you can get metadata using artificial directories.  But
this doesn't play well with apache.  I can't recall what the apache
and reiser developers decided to do about this, but should be able to
avoid the problem simply by turning "AllowOverride off" (assuming you
don't need .htaccess).

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message