httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] Apache 2.0 / Suexec2 Question
Date Wed, 19 Jan 2005 18:03:50 GMT
On Wed, 19 Jan 2005 12:32:39 -0500, Tom Ray [Lists]
<lists@blazestudios.com> wrote:
> Hey there-
> 
> I just created a web server with SuSE 9.1 straight from the box with
> Apache 2.0 my question is this: It seems that Suexec is installed
> because I see it give me this in the error_log [notice] suEXEC mechanism
> enabled (wrapper: /usr/sbin/suexec2), however, when I set
> SuexecUserGroup in the <VirtualHosts> section, I get a 500 Error tell me
> that it's Premature end of script headers but when I comment out the
> SuexecUserGroup so it runs as the webserver, everything runs fine.
> 
> Is there a way to fix that without re-compiling and if there isn't how
> do I recompile with --enable-suexec since I did everything via yast

Start by looking in the suexec_log to find the source of the problem.

If you can't find the suexec log, find the suexec binary and run
"suexec -V" as root to get the configuration details.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message