httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iurib...@secuenzia.com
Subject [users@httpd] Problems getting Auth LDAP to work with FPSE 2002
Date Wed, 26 Jan 2005 18:40:04 GMT
Hello,

I'm having problems getting the mod_auth_ldap to work with FPSE 2002, on
Apache 2.0.52 in Linux RedHat 3.0

1- I have installed Apache with mod_aut_ldap with the next command:

./configure --with-ldap --enable-ldap --enable-auth-ldap=shared

and after that I have installed the FontPage extensions.

2- I have modified the /usr/local/apache2/htdocs/.htaccess file that is in
the DocumentRoot as follow:

# -FrontPage-

IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

#<Limit GET POST>
#order deny,allow
#deny from all
#allow from all
#</Limit>
#<Limit PUT DELETE>
#order deny,allow
#deny from all
#</Limit>
#AuthName icmforms18.icm.es
#AuthUserFile /usr/local/apache2/htdocs/_vti_pvt/service.pwd
#AuthGroupFile /usr/local/apache2/htdocs/_vti_pvt/service.grp

AuthName icmforms18.icm.es
AuthType Basic
AuthLDAPAuthoritative off
AuthLDAPFrontPageHack on
AuthLDAPurl ldap://icm1003:389/ou=Usuarios,o=icm.es?uid
require valid-user

But I am not really sure if it is correct.

3- And I have modified /usr/local/apache2/htdocs/_vti_pvt/.htaccess
and /usr/local/apache2/htdocs/_vti_cnf/.htaccess

[root@icmforms18 _vti_pvt]# more .htaccess
# -FrontPage-

Options None

<Limit GET POST PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName icmforms18.icm.es
AuthUserFile /usr/local/apache2/htdocs/_vti_pvt/service.pwd
AuthGroupFile /usr/local/apache2/htdocs/_vti_pvt/service.grp

AuthType Basic
AuthLDAPurl ldap://icm1003:389/ou=Usuarios,o=icm.es?uid
AuthLDAPAuthoritative off
AuthLDAPFrontPageHack on


I have an user, "CONSU", that is able to authenticate with LDAP.

My problem is that when I try to public my web with the FrontPage client
tool I want to authenticate with LDAP but
I get the following error

[Wed Jan 26 19:20:22 2005] [error] [client 10.80.10.207] user CONSU:
authenticat
ion failure for "/_vti_inf.html": Password Mismatch

I expected that with the directive AuthLDAPFrontPageHack I could
authenticate only with LDAP. But It looks
like first It authenticate with LDAP and then with FrontPage.

Does anyone know what is the problem?

Thanks in advance!

Regards,
Iratxe

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message