httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean T Allen <s...@ardismg.com>
Subject Re: [users@httpd] Mod_rewrite help
Date Thu, 20 Jan 2005 16:04:32 GMT
Are you getting the error all the time or only when going through a vhost...

Have you turned on mod rewrite logging to get a better idea of what is 
going on?

Jorge Schrauwen wrote:

> Yes,
> Main config -> http
> vhost -> https
> vhost2 -> DAV
>  
> Jorge
> ------------------------------------------------------------------------
> *From:* Sean T Allen [mailto:sean@ardismg.com]
> *Sent:* Thursday, January 20, 2005 16:33
> *To:* users@httpd.apache.org
> *Subject:* Re: [users@httpd] Mod_rewrite help
>
> Then it probably is an issue somewhere else in your configuration...
>
> Are you using virtual hosting?
>
> Jorge Schrauwen wrote:
>
>> nope adding the [R,L] didn't help :(
>>  
>> Jorge
>>
>> ------------------------------------------------------------------------
>> *From:* Sean T Allen [mailto:sean@ardismg.com]
>> *Sent:* Wednesday, January 19, 2005 22:48
>> *To:* users@httpd.apache.org
>> *Subject:* Re: [users@httpd] Mod_rewrite help
>>
>>RewriteEngine on
>>RewriteRule ^/imageview5/view/(.*)/(.*) http://schrauwen.no-ip.org/imageview5/index.php?album=$1&file=$2
[R,L]
>>
>>  
>>
>>
>> Jorge Schrauwen wrote:
>>
>>>Ok now I have:
>>>---
>>>RewriteEngine on
>>>RewriteRule ^/imageview5/view/(.*)/(.*)
>>>http://schrauwen.no-ip.org/imageview5/index.php?album=$1&file=$2
>>>---
>>>And it olso doesn't work, error log line is still the same.
>>>
>>>Thanx again for the help
>>>
>>>Jorg
>>> 
>>>
>>>-----Original Message-----
>>>From: Brian V Hughes [mailto:brianvh@Dartmouth.EDU] 
>>>Sent: Wednesday, January 19, 2005 20:40
>>>To: users@httpd.apache.org
>>>Subject: Re: [users@httpd] Mod_rewrite help
>>>
>>>
>>>Have you tried putting in a line to turn on Rewrite logging? That way you
>>>can look through the log file to see exactly what mod_rewrite is doing to
>>>the request URLs.
>>>
>>>-Brian
>>>
>>>
>>>On Jan 19, 2005, at 02:37 PM, Jorge Schrauwen wrote:
>>>  
>>>
>>>>No, still doesnt work, i still get a 404.
>>>> 
>>>>I tried from .htaccess and httpd.conf, same result
>>>> 
>>>>--- error.log ---
>>>>[Wed Jan 19 20:34:10 2005] [error] [client 192.168.2.4] File does not
>>>>exist: S:/wwwroot/imageview5/view
>>>> 
>>>>thanx for the help though
>>>> 
>>>>Jorge
>>>>    
>>>>
>>>
>>>
>>>---------------------------------------------------------------------
>>>The official User-To-User support forum of the Apache HTTP Server Project.
>>>See <URL:http://httpd.apache.org/userslist.html> for more info.
>>>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>>>For additional commands, e-mail: users-help@httpd.apache.org
>>>
>>>
>>>---------------------------------------------------------------------
>>>The official User-To-User support forum of the Apache HTTP Server Project.
>>>See <URL:http://httpd.apache.org/userslist.html> for more info.
>>>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>>>For additional commands, e-mail: users-help@httpd.apache.org
>>>
>>>
>>>  
>>>
>>
>


Mime
View raw message