httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Sammis <csam...@cs.iastate.edu>
Subject Apache2 (RedHat Enterprise) isn't logging using SetEnv VLOG
Date Tue, 04 Jan 2005 17:59:18 GMT
A week and a half ago we transitioned to a new web server running RedHat 
Enterprise 3 and Apache 2.0.46. We have a lot of vhosts, and they all 
want their own logs, so we used the SetEnv VLOG method of logging. 
However, that isn't working on the new server. VLOG log files aren't 
getting written. Here's what I've tried:

* Turning up the error level on the error log (which is working). It 
doesn't show anything out of the ordinary.
* Using a combined log file. The combined logfile writes properly, but 
that won't work for our setup.
* Checking directory permissions. Everything's okay, like I said the 
combined log file and error log files operate normally.
* Manually calling the split-logfile script and injecting a couple of 
made-up log lines. That works correctly too, the made-up lines are 
appended to the appropriate VLOG file.
* Putting some bad syntax into the split-logfile script and seeing what 
happens. The error log starts filling up with "script failed 
unexpectedly" messages, so apparently the server is calling the script.

Here's the relevant lines of httpd.conf. They're copied verbatim out of 
the old apache2.conf and placed at the end of the file so they aren't 
getting overriden by anything.

LogFormat "%V %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" 
\"%{User-Agent}i\" VLOG=%{VLOG}e" vhosts
SetEnv VLOG ""
CustomLog "|/usr/sbin/split-logfile" vhosts env=VLOG

All other CustomLog directives are commented out, and that's the only 
SetEnv VLOG directive present.
Anyone have any ideas for troubleshooting I haven't tried yet? Thanks.

-- 
Chris Sammis
On the Web: http://csammisrun.net
"Computer science is no more about computers than astronomy is about telescopes" -- E. J.
Dijkstra


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message