httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Campbell" <apa...@evasive.com>
Subject RE: [users@httpd] ForceType not working properpy for httpd-2.0.52-3.1
Date Tue, 18 Jan 2005 01:47:38 GMT
Well, that fixed my problem.  I think between the combination of a late night, my not knowing
how to find out the "Content Type" via
the command line and fighting with IE cache, I just couldn't get this to work properly.  

I say that because I just made that change to Directory this morning so last night I know
I was using Directory "properly".

I'm confused about Directory.  I thought that Directory used DocumentRoot because of information
here:

http://httpd.apache.org/docs-2.0/mod/core.html#directory 

there is an example at the bottom of that section that looks like the following:

<Directory />
   Order Deny,Allow
   Deny from All
</Directory>

Which leads me to believe that Directory is DocumentRoot based (else why use /??)

Anyway, thank you very much for the assistance!
Thomas


> -----Original Message-----
> From: Joshua Slive [mailto:jslive@gmail.com]
> Sent: Monday, January 17, 2005 5:17 PM
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] ForceType not working properpy for httpd-2.0.52-3.1
> 
> On Mon, 17 Jan 2005 14:01:40 -0800, Thomas Campbell <apache@evasive.com> wrote:
> >   <Directory        /test>
> >      ForceType      text/plain
> >   </Directory>
> 
> <Directory> is relative to the filesystem root, not the DocumentRoot.
> You need to tack on your DocumentRoot directory to the front of /test
> if you want that to work.
> 
> Joshua.
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG Anti-Virus.
> Version: 7.0.300 / Virus Database: 265.6.13 - Release Date: 1/16/2005




-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.300 / Virus Database: 265.6.13 - Release Date: 1/16/2005


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message