httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: [users@httpd] Apache 2.0.52 segfaults
Date Tue, 04 Jan 2005 15:58:32 GMT
On Fri, Dec 31, 2004 at 04:45:01PM -0800, Jim Norton wrote:
> On Fri, Dec 31, 2004 at 01:09:11PM -0800, Jim Norton wrote:
> > I'm running a Gentoo Linux box and recently tried to upgrade PHP to
> > the newest version that fixes the recently found security
> > vulnerability in PHP.
> > 
> > Well, I also upgraded Apache from 2.0.48 to 2.0.52 and now when I
> > try to start the server, I get a segmentation fault.
> > 
> > Anbyody have any idea at all how I can go about diagnosing what is
> > causing this behavior?
...
> Program received signal SIGSEGV, Segmentation fault.
> 0xb7b4ab6c in memcpy () from /lib/libc.so.6
> (gdb) bt
> #0  0xb7b4ab6c in memcpy () from /lib/libc.so.6
> #1  0xb7cd9cbb in call_resolver () from /usr/lib/libapr-0.so.0
> #2  0xb7cd9e33 in find_addresses () from /usr/lib/libapr-0.so.0
> #3  0xb7cd9ead in apr_sockaddr_info_get () from /usr/lib/libapr-0.so.0

This seems to be a system library issue which Gentoo users suffer from
occasionally, see this bug report:

http://issues.apache.org/bugzilla/show_bug.cgi?id=29128#c11:

joe

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message