httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leif W" <warp-...@usa.net>
Subject Re: [users@httpd] LimitRequestBody setting to maximize the upload file size (please help)
Date Fri, 07 Jan 2005 23:39:50 GMT
> Joe Smith; 2005 January 07 Friday 10:52
>
> I added the line LimitRequestBody 204800000 to
> /usr/HTTPServer/conf/httpd.conf, in order to maximize the upload file

First of all, is that the correct context?  According to the manual ( 
http://httpd.apache.org/docs-2.0/mod/core.html#limitrequestbody ), this 
directive can appear in the main server config or in virtual server ( 
<VirtualHost> ) sections.  It may be that you have put the directive in 
the main server config, yet you're trying to control the VirtualHost and 
it's not being seen or inherited.  I do not know if this directive in a 
server context will automatically be inherited by a virtual server.  It 
may be.  Perhaps someone else can shed light upon that behavior.

> size. Currently, the Apache web server returns HTTP response
> "HTTP/1.1 413 Request Entity Too Large" immediately to the browser if
> file size > 10MB.

Second of all, there may be other mechanisms which are limiting file 
upload size besides Apache.  Are you using a specific script to upload 
the file?  The scripting engine (such as PHP) can configure and impose 
its own file upload limitations, for instance, and an upload script may 
be written in such a way as to produce an error response with headers as 
you've shown.  So can Perl's CGI.pm module.

> Even I added LimitRequestBody setting, and restarted the server by 
> sudo
> /usr/HTTPServer/bin/apachectl stop, sudo /usr/HTTPServer/bin/apachectl
> start, it is still unable to upload a huge file size.
>
> By the way, this is the HTTP response:
> HTTP/1.1 413 Request Entity Too Large
> Date: Thu, 06 Jan 2005 00:25:50 GMT
> Server: IBM_HTTP_SERVER/1.3.26.2  Apache/1.3.26 (Unix)
> Connection: close
> Transfer-Encoding: chunked
> Content-Type: text/html; charset=iso-8859-1
>
> any ideas? please help. thanks!!

If you change an Apache config, and do not see the expected results, 
it's either the wrong config file, wrong context, possibly wrong syntax 
(even though a syntax check is OK and Apache starts without error 
messages and runs normally except for the behavior you're trying to 
modify), or possibly something outside of Apache.  If it is within 
Apache, check your error logs to see and verify at what point the 
failure occurs if it's caused by Apache.

Leif



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message