httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From peter pilsl <pi...@goldfisch.at>
Subject [users@httpd] fail to serve static unicode-file proper
Date Tue, 07 Dec 2004 22:41:04 GMT

I deal a lot with unicode/utf8. Usually I generate the content 
dynamically and just print out a Content-Type-line including a 
charset-command as Header and everything is fine.

Now I want to present a static utf-8 page and I fail.

My first attempt was to add an appropriate meta-tag to the source:

<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
</head>

When this did not work I inspected my config and found:

AddLanguage de .de
AddCharset UTF-8       .utf8

So I renamed my text.html into text.de.utf8 and .. again my browser 
(Firefox 1.0) showed the page using the iso-8859-1-charset.

So finally I tried the AddDefaultChard utf8 in the .htaccess for the 
folder where my text was in, only to get an error and the error-log 
stated that
/data/apache/myfolder/.htaccess: AddDefaultCharset not allowed here


whoops? Next step is to write a small cgi that reads the text and print 
an appropriate header. But I'm sure there is a way to present static 
unicode-text.

thnx,
peter





-- 
mag. peter pilsl
goldfisch.at
IT-management
tel +43 699 1 3574035
fax +43 699 4 3574035
pilsl@goldfisch.at

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message