httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benny Sun <acidbre...@gmail.com>
Subject [users@httpd] Re: Has RewriteRule changed in functionality?
Date Sat, 04 Dec 2004 21:23:47 GMT
Actually, it doesn't give me a 500, just does nothing.


On Sat, 4 Dec 2004 15:17:38 -0600, Benny Sun <acidbreeze@gmail.com> wrote:
> I am having issues with mod_rewrite's RewriteRule on both Apache
> 1.3.33 and 2.0.52.
> 
> According to an example at
> (http://httpd.apache.org/docs-2.0/mod/mod_rewrite.html#rewritecond), I
> am supposed to be able to use:
> 
> ===================
> RewriteCond  %{HTTP_USER_AGENT}  ^Mozilla.*
> RewriteRule  ^/$                 /homepage.max.html  [L]
> ===================
> 
> Instead, I have to use:
> 
> ===================
> RewriteCond  %{HTTP_USER_AGENT}  ^Mozilla.*
> RewriteRule  ^$                 /homepage.max.html  [L]
> ===================
> 
> ...without the forward slash. Placing the first in my .htaccess file
> gives a HTTP 500, and my error log complains of too many redirects. I
> noticed this with all my other rules. Is this supposed to be?
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message