httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matej Cepl <c...@surfbest.net>
Subject [users@httpd] NB: Making apache into webdav server
Date Sun, 12 Dec 2004 03:14:41 GMT
Hi,

I am probably a really clueless newbie, but I have a problem to make Apache
1.3.26 (on Debian/woody) working as a WebDAV server (so far a testing
installation on my home server).

I have installed apache, apache-doc, libapache-mod-dav and cadaver (all
standard packages from debian/stable) and I have created a
simple /etc/httpd.conf (viz. see attached diff; BTW does anybody know what
is the correct value of MIMEMagicFile in Debian, the current share/magic
gives me an error on startup of Apache -- but I do not think, that it
should be related to my problems?), I run apacheconfig, and created the
dav/ directory in /var/www/ (which is DocumentRoot on Debian):

mitmanek:matej$ ls -l /var/www/
total 12
drwxr-xr-x    2 www-data www-data     4096 pro 11 00:56 dav
-rw-r--r--    1 root     root         4110 lis 12 12:07 index.html
mitmanek:matej$

and these files in /etc/apache

mitmanek:matej$ ls -l /etc/apache/
total 216
-rw-r--r--    1 root     root          285 pro 10 21:00 access.conf
lrwxrwxrwx    1 root     root            1 pro 10 21:00 conf -> .
-rw-r--r--    1 root     root        35579 pro 11 02:21 httpd.conf
-rw-r--r--    1 root     root        12554 pro 10 21:00 httpd.conf.8.gz
lrwxrwxrwx    1 root     root           13 pro 10 21:00 mime.types \
 -> ../mime.types
-rw-r-----    1 root     www-data       42 pro 11 02:06 passwd.dav
-rw-r--r--    1 root     root          297 pro 11 01:10 srm.conf
-rw-r--r--    1 root     root          297 pro 10 21:00 srm.conf.0
mitmanek:matej$

(passwd.dav was created with htpasswd and when I look into it, there is my
login and something encrypted as my password, so it should be OK; I hope).

However, when I try to connect to the WebDAV directory with cadaver (or
webdav://mitmanek/dav/ in konqueror; these are from Debian/testing) I get
an error:

blahoslav:matej$ cadaver http://mitmanek/dav/
Authentication required for DAV Restricted on server `mitmanek':
Username: matej
Password:
Could not access dav (not WebDAV-enabled?):
404 Not Found
Connection to `mitmanek' closed.
dav:!>
blahoslav:matej$

I am quite sure, that the password is correct (I have tried all these things
many times, so there should not be a problem of not restarting apache or
something like that).

Do you have any idea, what's wrong with me, please?

Thanks for any kick into the right direction,

Matej

-- 
Matej Cepl, http://www.ceplovi.cz/matej
GPG Finger: 89EF 4BC6 288A BF43 1BAB  25C3 E09F EF25 D964 84AC
138 Highland Ave. #10, Somerville, Ma 02143, (617) 623-1488
 
Really, I'm not out to destroy Microsoft. That will just be
a completely unintentional side effect.
      -- Linus Torvalds
         New York Times, 28 Sept 03
Mime
View raw message