httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] Config problem with Apache/PHP
Date Thu, 04 Nov 2004 18:33:11 GMT
On Thu, 4 Nov 2004 17:56:16 -0000, Kathy <riviere@homechoice.co.uk> wrote:
> However, a script that used to work on the old server (still does, so I know
> the script is working ok) does not work anymore on the new Linux/Apache
> server,but gives a 404 error. For this reason I think it must be the Apache
> configuration 
>   
> The script is called from another page and should output a downloadable
> excel file.  The data is there,  but it seems that Apache, instead of
> running the file as a script, looks for a page to serve, does not find it
> and so returns the 404 error. 

> The following  link that should produce the file to download is as follows 
> <a href="csvout.php/dataout.xls?ID=<?php echo $row_obs['Cp_ID']; ?>"> 
> 
>   
> The file dataout.xls should be produced and is by the old server, but not by
> the new. 

You're omitting some crucial info like the version of apache and the
relevant lines of the error and access logs.

One guess is that you are using an old broken version of php and
apache, and therefore need to set the "AcceptPathInfo On" directive in
httpd.conf.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message