httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reid, Cherie" <Cherie.R...@workcover.nsw.gov.au>
Subject [users@httpd] Configuring the httpd.conf file to use the AuthenNTLM module with an Apache 1.3 / Unix environment
Date Tue, 23 Nov 2004 04:09:46 GMT
Hi All

I have installed the AuthenNTLM module with no problems but am getting errors when I try to
restart Apache after changing the httpd.conf file

I have added the following to httpd.conf

<Directory "[cgi-bin I want protected]">
AuthType ntlm,basic
AuthName test
AuthUserFile [location of password file
require valid-user
#
PerlAddVar ntdomain "[domain bdc]"
PerlSetVar defaultdomain [domain]
PerlSetVar splitdomainprefix 1
PerlSetVar ntlmdebug 1
</Directory>

But I get the error:
Syntax error on line 949 of /usr/local/conf/httpd.conf:
Invalid command 'PerlAuthenHandler', perhaps mis-spelled or defined by a module not included
in the server configuration

Is there something else I am suppose to add to this file to indicate I wanted to use this
module?
This is probably a really simple problem to fix but I can't find a solution on perldoc. I
am only new to Apache. I have read that it could be the permissions on the include directory
but am unsure what this is.

Any help will be greatly appreciated.

Thank you

Cherie

****************************************************************************************************************************************

This message, including any attached files, is intended solely for the addressee named and
may contain confidential 
information. If you are not the intended recipient, please delete it and notify the sender.
Any views expressed in this 
message are those of the individual sender and are not necessarily the views of WorkCover
NSW.

****************************************************************************************************************************************

 

 

 

 

 

 

 

 

 
 
 
 

Mime
View raw message