httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chuck Amadi <ch...@smtl.co.uk>
Subject [users@httpd] Warning: DocumentRoot [/www/manual] does not exist while trying to run a mod_chroot Apache 2
Date Wed, 10 Nov 2004 10:39:02 GMT
Hi I am a SysAdmin our Organisation is a Linux/SuSE shop we have a
Chrooted Apache2 in testing with virtual hosting and Zope/Plone websites
.

My boss has suggested to use the less taxing mod_chroot
which I have configured as follows :

SuSE Linux O/s Apache 2 httpd.conf file

ServerRoot "/usr/apache2/apache-test"
ChrootDir "/chroot/apache2/www"
DocumentRoot "/"

PidFile "/www/

<VirtualHost *:80>
ServerName server.company.co.uk
DocumentRoot "/www/manual"
#DocumentRoot "/manual" # tried this as well .
</VirtualHost>

Thus when I run  ./apachectl restart
Warning: DocumentRoot [/www/manual] does not exist

Also this when I changed the DocumentRoot to "/manual"

Warning: DocumentRoot [/manual] does not exist

I have read the mod_chroot doc's but cant find the problem as I have
created the neccessary directories and my html files reside in the dir
in question /chroot/apache2/www/ where my websites resides .

Is there any more examples out there in relation to using mod_chroot for
Apache 2 Linux .

Cheers

Chuck


-- 
Chuck Amadi, Systems Administrator, |  http://www.smtl.co.uk/
Surgical Materials Testing Lab,     |  http://www.worldwidewounds.com/
Princess of Wales Hospital, S Wales |  http://www.dressings.org/
Tel/Fax: +44 1656-752820            |  chuck@smtl.co.uk


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message