httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] rewriteRule problem
Date Fri, 15 Oct 2004 17:37:12 GMT
On Fri, 15 Oct 2004 10:23:15 -0700 (MST), Donald Raikes <don@draikes.com> wrote:
> I added the rule:
> RewriteRule (.*)\.gif
> http://access.us.oracle.com:8888/st-acc2/cabo/images/$1.gif [P,L]
> 
> This worked for all but 2 images.
> The other two images are in a different folder.
> 
> I tried adding:
> RewriteRule (.*)disabled3.gif
> http://access.us.oracle.com:8888/st-acc2/disabled3.gif$1 [P]
> 
> but when I try to reference the disabled3.gif using:
> http://staccessibility.us.oracle.com/disabled3.gif,
> I get a 404 file not found
> http://access.us.oracle.com:8888/st-acc2/cabo/images/disabled3.gif
> 
> What is wrong with my rules?

Have you use the RewriteLog?  It is pretty-much essential when dealing
with mod_rewrite.

You'll probably find there that the *.gif rule is applying first, and
therefore your disabled3.gif rule never gets a chance.  List the more
specific rule first in the config file and add an L to the flags to
make sure the other rule doesn't get used.

I also don't see why you are tagging the $1 on to the end of the URL.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message