httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Klug <brian.k...@gmail.com>
Subject Re: [users@httpd] apache 2 zombie(?) processes with worker MPM
Date Sat, 23 Oct 2004 19:19:32 GMT
> > Once or twice a week during peek hours (20 requests/sec) it seems like
> > httpd loses track of what children it has.  'ps' will show 7 or 8
> > httpd processes - 1 parent process, 3 child processes (that match up
> > when I look at /apache-status), and a bunch of other httpd's that
> > seemingly have no purpose in life other then to use up precious
> > memory.
> 
> Hmmm.... You don't mention what precise version or what modules you are using.

httpd-2.0.52, mod_perl-1.99_14.

> I assume that you are sure that these other processes are not CGI
> scripts, or mod_cgid control processes?

Wouldn't CGI scripts show up under 'ps' as the actual executable, not as httpd?

In any event, /server-status shows everything as normal.  Its not like
there are a bunch of children hung in 'W' -- the processes aren't
listed at all.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message