httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kvetch <kve...@gmail.com>
Subject [users@httpd] Root Apache process disappears
Date Fri, 08 Oct 2004 13:36:22 GMT
Hello, I am running Apache 2.0.51 and am experiencing some problems. 
I have noticed since I installed it a few days ago that my root
process disappears.  I have needed to add some Virtual Hosts to it
everyday but when I go to stop and start Apache it cannot stop because
the root Apache process is missing.  I look at my httpd.pid file and
see the PID number but that PID is not running anymore.  I am forced
to kill all the processes running and the start Apache.  Why would my
root process disappear?  How can I correct the issue.  I compile
Apache with Prefork MPM and SSL.  I don't know if it matters but I
have 3 IP's on this machine with about 220 Virtual Hosts and 2 SSL
sites.  One IP address is running 2 sites, one IP is running 1 SSL
site, the other IP is running 218 Virtual Hosts and 1 SSL host.  A few
of the sites run some old CGI's - one of which is randomly timing
out/failing due to some network issue currently going on.  the CGI is
making a call to another server which is having network issues, so the
CGI randomly fails.  Would this cause my root process to disappear. 
Below is my error log (which doesn't look like too big of a deal)
I am running RedHat Ent.3 - Dual 2.4 Xeon with 1gb of ram.

Thanks,
Nick

Error_Log - 
[Fri Oct 08 08:55:46 2004] [debug] prefork.c(955): AcceptMutex:
sysvsem (default: sysvsem)
[Fri Oct 08 08:55:50 2004] [info] server seems busy, (you may need to
increase StartServers, or Min/MaxSpareServers), spawning 8 chi
ldren, there are 46 idle, and 57 total children
[Fri Oct 08 08:56:01 2004] [info] server seems busy, (you may need to
increase StartServers, or Min/MaxSpareServers), spawning 8 chi
ldren, there are 46 idle, and 72 total children

My Prefork settings - 
<IfModule prefork.c>
StartServers        50
MinSpareServers     50
MaxSpareServers    150
MaxClients         256
MaxRequestsPerChild  0
</IfModule>

Here is some stats on my build - 
Compiled in modules:
  core.c
  prefork.c
  http_core.c
  mod_so.c

Server version: Apache/2.0.51
Server built:   Sep 23 2004 09:08:53
Server's Module Magic Number: 20020903:9
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/usr/local/apache"
 -D SUEXEC_BIN="/usr/local/apache/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message