httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias Herp <m...@tobias-herp.de>
Subject [users@httpd] NameVirtualHost ... has no VirtualHosts
Date Wed, 15 Sep 2004 08:36:31 GMT
Hi, everyone,

I run Apache 2.0.49 on a virtual server with SuSE 9.0. Before the system 
got updated, I ran Apache 1.3.x, and my VirtualHosts worked fine; they 
don't work anymore.

When I restart the server, I get the message:
Starting httpd2 (prefork) [Wed Sep 15 01:17:44 2004] [warn] 
NameVirtualHost 62.75.158.127:80 has no VirtualHosts

The output of "/usr/sbin/httpd2-prefork -S" is:
[Wed Sep 15 00:46:00 2004] [warn] NameVirtualHost 62.75.158.127:80 has 
no VirtualHosts
VirtualHost configuration:
62.75.158.127:80 is a NameVirtualHost
default server sandbox.tobias-herp.de (/etc/apache2/myVirtualHosts.conf:1)
port 80 namevhost sandbox.tobias-herp.de 
(/etc/apache2/myVirtualHosts.conf:1)
port 80 namevhost htmlarea.demo.tobias-herp.de 
(/etc/apache2/myVirtualHosts.conf:9)
port 80 namevhost htmlarea3.demo.tobias-herp.de
(...)
port 80 namevhost zope.tobias-herp.de (/etc/apache2/myVirtualHosts.conf:77)
Syntax OK

Whenever I try to access any page on a subdomain of my server 
(regardless whether or not it is configured), I get the same error page:
snip>
Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use 
an ErrorDocument to handle the request.
Apache/2.0.49 (SuSE Linux 9/Server4You) Server at 
htmlarea3.demo.tobias-herp.de Port 80
<snip

The virtual hosts are redirected to Zope via RewriteRules (which worked 
fine with Apache 1.3), so operating system/file access issues shouldn't 
be the cause. At least http://htmlarea3.demo.tobias-herp.de (or 
http://www.htmlarea3.demo.tobias-herp.de) should work, but it doesn't. 
Zope is up and running, of course, and it contains a VirtualHostMonster; 
http://tobias-herp.de:8080/htmlArea3Demo/ works fine.

Any ideas? Thanks in advance!

Tobias


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message