httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] Problems Building and Using mod_proxy_html
Date Thu, 09 Sep 2004 17:17:57 GMT
On Thu, 9 Sep 2004, Will Cline wrote:

> Folks, I have been attempting to use mod_proxy_html and have a couple of
> problems and was hoping someone might offer some suggestions:

Are you the William Cline who contacted me from an nc.rr.com address?
I tried to reply, but nc.rr.com won't accept email from me, either to
you or to postmaster.

> mod_proxy_html.c && touch mod_proxy_html.slo
> mod_proxy_html.c: In function `proxy_html_filter':
> mod_proxy_html.c:757: `XML_PARSE_RECOVER' undeclared (first use in this
> function)

I think you must have got the header files from an older version of
libxml2.  Those options are a relatively recent addition.  I'm not
quite sure when they were introduced; possibly 2.6.0 or maybe later.

> I can comment out these lines in the mod_proxy_html.c file (Is there
> something wrong with libxml? I installed both the rpm - the base and devel
> rpms) - I also have the source.

Yes, commenting those out won't hurt, it'll just make a marginal
difference to how well it deals with malformed HTML coming from a backend.

-- 
Nick Kew

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message