httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Szarka <szli...@szarka.org>
Subject [users@httpd] PDF plug-in issues under 2.0.48
Date Mon, 27 Sep 2004 13:49:44 GMT

I am running the stock SUSE build of the 2.0.48 version of httpd2-prefork 
with all the latest updates applied. On migrating sites from an old 1.3.22 
install on another server, I saw problems with PDF files on clients running 
MSIE. I have a workaround in place, but not really a solution.

Symptom:

The MSIE client tries to load the PDF (presumably using the Adobe plug-in), 
but fails with the message "File does not begin with '%PDF'". The log file 
shows two consecutive hits, the first with a 200 error code and the second 
with a 206. There are no problems loading the file in Mozilla.

Things That Don't Seem To Work:

I found several similar problem reports on this list, in bugzilla, and 
elsewhere, some with proposed solutions.

Some were due to using mod_deflate on the content, but I am not. I tested 
with the module not loaded at all to be sure.

Others suggested keeping IE from using chunked encoding through a directive 
sucj as "SetEnvIf Request_URI "\.pdf$" nokeepalive" or "<FilesMatch "\.pdf$" >
    BrowserMatch MSIE nokeepalive downgrade-1.0 force-response-1.0
</FilesMatch>". This seemed to be on the right track (see below), but, 
assuming I applied those directives correctly, it didn't work.

Rob Baily reported a problem with large PDF files in 2.0.49, but he wrote 
that the problem doesn't occur in 2.0.48. The files I'm testing are <1MB; 
not sure what "large" means in this context. Bug #25960 suggests that 
"large" is >90kb, but I haven't tested with <90kb files yet.

Workaround:

On both the old and new servers my mime type for .pdf files was 
"application/pdf". Changing this to "application/x-pdf" (also tried 
"application/pdf pdf", which makes no difference in either MSIE or Mozilla) 
results in MSIE downloading the entire file and loading it in Acrobat 
(apparently as a helper rather than a plug-in) instead of trying to request 
and display it a piece at a time.

Unfortunately, this also results in Mozilla (understandably) reporting an 
unknown MIME type and prompting the user for action (the default action 
being to load into Acrobat).

Solution?:

Has anyone experienced and solved this problem? Should I submit a bug report?

Until this problem is solved, is there a way to get Apache to send 
different MIME types to different browsers as a better workaround?
-- 
Surf the Sea of Noise!  http://seaofnoise.com/blosxom/


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message