httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Goodes <d...@planetmirror.com>
Subject Re: [users@httpd] <Directory> and <Location>
Date Thu, 26 Aug 2004 23:22:00 GMT
On Thu, 26 Aug 2004 at 09:47, Joshua Slive wrote:

> On Thu, 26 Aug 2004 15:06:43 +1000 (EST), Dan Goodes
> <dang@planetmirror.com> wrote:
> >
> > As i said, the problem is that in the latter configuration, none of the
> > Location sections (including the catch-all <Location "/pub*">) actually
> > match (i.e. no Layout stuff is actually implimented, etc, regardless of
> > the URL).
>
> Note the "*" on the end is not necessary.  <Location> does substring matches.

I realise it shouldn't be necessary, however I was trying pretty much
everything I knew to get it to work.

> Have you tried non-mod_layout directives (like just Allow/Deny for
> example) to see if they work?  This could be a bug in mod_layout.

Note that none of the directives in there work. The rewrite rules, the
IndexOptions. It's almost like apache it either ignoring the directive
altogether, or isn't getting a location match for /pub/anything.

--Dan


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message