httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Locke <m...@freelock.com>
Subject [users@httpd] Log records in two timezones
Date Sun, 29 Aug 2004 18:58:04 GMT
Hello,

I've installed the AWstats package on my server, to analyze the server 
logs. However, there seems to be a problem with the log files generated 
by Apache: Almost all log records are in the local timezone ( -0700 ). 
But every now and then, Apache logs a request in UTC.

For example:

66.26.84.147 - - [10/Aug/2004:18:52:55 -0700] "GET 
/product_images/83860_479_s.jpg HTTP/1.1" 200 21479 
"http://www.orgear.com/home/category/home/headware/cold_hats/wind_hats" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)" 
326 21846
66.26.84.147 - - [11/Aug/2004:01:52:55 +0000] "GET 
/product_images/83810_258_s.jpg HTTP/1.1" 200 8637 
"http://www.orgear.com/home/category/home/headware/cold_hats/wind_hats" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)" 
326 9003
66.26.84.147 - - [10/Aug/2004:18:52:55 -0700] "GET 
/product_images/83850_880_s.jpg HTTP/1.1" 200 21156 
"http://www.orgear.com/home/category/home/headware/cold_hats/wind_hats" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)" 
326 21523
66.26.84.147 - - [10/Aug/2004:18:52:56 -0700] "GET 
/product_images/83895_880_s.jpg HTTP/1.1" 200 20714 
"http://www.orgear.com/home/category/home/headware/cold_hats/wind_hats" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)" 
326 21081
66.26.84.147 - - [11/Aug/2004:01:52:56 +0000] "GET 
/product_images/83840_250_s.jpg HTTP/1.1" 200 21819 
"http://www.orgear.com/home/category/home/headware/cold_hats/wind_hats" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)" 
326 22186
66.26.84.147 - - [10/Aug/2004:18:53:10 -0700] "GET 
/home/category/home/headware/rain_hats HTTP/1.1" 200 11054 
"http://www.orgear.com/home/category/home/headware/cold_hats/wind_hats" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)" 
494 11328


This happens very rarely--33 times out of over 250,000 hits in one 
recent weekly log file--but it's enough to make Awstats reject 7 hours 
worth of log records each time it happens. Awstats apparently expects 
all log entries to be in the same timezone, rejecting the timezone 
portion of the timestamp.

Any suggestions for making Apache log everything in a single time zone?

Environment: Red Hat 7.3, httpd 2.0.48, mod_log_config, mod_log_io

Cheers,
-- 
John Locke
Open Source Solutions for small business problems
http://www.freelock.com


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message