httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Covington, Chris" <ccoving...@plusone.com>
Subject RE: [users@httpd] Reverse Proxy --- Exchange
Date Tue, 24 Aug 2004 12:41:54 GMT
Al,

Search through the archives.  This is what I use with Apache 2.0.49 (I
don't know how you'd do it with 1.3):

I've noticed sometimes OWA will request /Exchange instead of /exchange,
etc.  So I far I've using the following for the last few months w/o
problems:

ProxyPreserveHost On

#OWA
ProxyPass /exchange https://exchangesrvr.example.com/exchange
ProxyPassReverse /exchange https://exchangesrvr.example.com/exchange
ProxyPass /Exchange https://exchangesrvr.example.com/exchange
ProxyPassReverse /Exchange https://exchangesrvr.example.com/exchange
ProxyPass /exchweb https://exchangesrvr.example.com/exchweb
ProxyPassReverse /exchweb https://exchangesrvr.example.com/exchweb
ProxyPass /public https://exchangesrvr.example.com/public
ProxyPassReverse /public https://exchangesrvr.example.com/public
ProxyPass /iisadmpwd https://exchangesrvr.example.com/iisadmpwd
ProxyPassReverse /iisadmpwd https://exchangesrvr.example.com/iisadmpwd

#OMA
ProxyPass /oma https://exchangesrvr.example.com/oma
ProxyPassReverse /oma https://exchangesrvr.example.com/oma

Chris 

-----Original Message-----
From: Al Sparks [mailto:data345@yahoo.com] 
Sent: Monday, August 23, 2004 10:05 PM
To: Apache Users
Subject: [users@httpd] Reverse Proxy --- Exchange

I'm running Apache/1.3.31.  I have the following mods:

  http_core.c
  mod_env.c
  mod_log_config.c
  mod_mime.c
  mod_negotiation.c
  mod_status.c
  mod_include.c
  mod_autoindex.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_access.c
  mod_auth.c
  mod_proxy.c
  mod_so.c
  mod_setenvif.c
  mod_ssl.c
  mod_php4.c

I'm trying to do a reverse proxy with an exchange server (Exchange
2003).  When I attempt to connect, I receive a framed page back, and
both frames give me "Action canceled" errors on them.

The proxy entries are:

        ProxyPass /mail http://server.domain.local/exchange
        ProxyPassReverse /mail http://server.domain.local/exchange

I've successfully proxied to non IIS servers, so I know that I've got
proxying in general working.

Any hints?  Do I need to upgrade to apache 2.x?
   === Al


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message