httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Chandler <a...@chandlerfamily.org.uk>
Subject Re: [users@httpd] PHP not working with apache2
Date Sun, 15 Aug 2004 02:31:18 GMT
On Sunday 15 August 2004 00:40, Grant wrote:
> I'm running Gentoo Linux, and emerged (installed)
> squirrelmail which automatically installed all of its
> dependencies including PHP and (I think) mod_php.  PHP
> doesn't seem to be working though, as I always end up
> looking at the raw PHP code in a browser.  I do have
> apache and apache2 installed on my system, and I
> suspect some key PHP things may have been set up for
> apache instead of apache2.  Does anyone have any
> pointers?

I don't know how you check the dependency chain in gentoo, but in debian there 
is a similar issue.  The package for php under apache2 is different to the 
one under apache1, and so just relying on default dependencies for some 
packages effectively loads up apache1 and php - but you are running apache2 
on the port your browser connects to and doesn't have php installed.

On debian the package that has to be used is called "libapache2-mod-php4"

-- 
Alan Chandler
alan@chandlerfamily.org.uk
First they ignore you, then they laugh at you,
 then they fight you, then you win. --Gandhi

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message