httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene Lee <list-apa...@fsck.net>
Subject Re: [users@httpd] Directory index forbidden by rule:/var/www/html/
Date Tue, 10 Aug 2004 07:10:03 GMT
I'm no expert in Linux or anything .NET.  But isn't restarting your
Linux box a little extreme?  Have you tried manually stopping Apache
and starting it back up again?  Anything good in Apache's error log?
Anything good in the Linux system logs?  How much RAM is being used
by what processes?  Anything gone to swap?  Does mod_mono have any
debugging features that, once enabled, report any useful messages?
If you start up Apache and then leave it alone for 30 minutes, does
your ASP.NET application still freeze up?


On Tue, Aug 10, 2004 at 02:11:00AM +0000, Singh Sardar wrote:
> 
> To be precise lemme tell you what behaviour am i facing.I have developed an 
> ASP.NET application using C# and i want to run it on RHL 9.0/Apache2.0 
> using mod_mono Mono 1.0.I have installed everything successfully(i guess 
> so) from Daniel's notes step by step.Now if i run the same application 
> under windows/IIS it runs PERFECT absolutely but when i run it under RHL 
> 9.0/Apache 2.0/mod_mono/Mono 1.0, i get the weird behaviour.It run fine for 
> some time...but after some time it seems that the connection to the server 
> is lost if the application is left idle(probably 30 minutes).It starts 
> giving the SERVER ERROR HTTP 500 for this particular application.If i try 
> accessing the other directory under root i.e /mrtg that also works fine but 
> the problem is with this particular application only which use C# with mono 
> run time.In order to fix that problem i need to restart the linux box and 
> everything starts running perfectly.I dont know what the problem lies in 
> and how to fix that up. I am using Session variables. I haven't checked the 
> cookie settings on my Windows and redhat box, but I'd like to know and 
> change any setting that can run my web app without crashing. Any help or 
> useful links will be of great help.I have checked out the error_log file 
> and it says that [client 10.6.10.19] Directory index forbidden by rule: 
> /var/www/html/. If i reboot the linux box now it will start working 
> perfectly without changing any permissions at all . btw the permission to 
> the directory where i have placed my app is 777 and its chowned by apache 
> and groupd is also apache.
> All the help will be highly appreciated.Somebody please help...to figure 
> out this behaviour

-- 
Eugene Lee
eugene at fsck dot net

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message