httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] SSI Question
Date Tue, 27 Jul 2004 15:28:10 GMT
On Tue, 27 Jul 2004 08:10:44 -0700 (PDT), Barry H <met_boy04@yahoo.com> wrote:
> Hello Folks,
> 
> I'm having trouble getting my server side includes to
> execute. The server is seeing them as comments in the
> html code.

> I have the following in my httpd.conf:
> 
> AddType text/html .shtml
> AddHandler server-parsed .shtml
> Options +Includes
> 
> and my SSI code looks like this:
> <!--#exec cgi="/cgi-bin/foo.cgi" -->
> 
> I checked the FAQs and saw lot's of info on
> configuring SSI, but nothing on this specific problem.
> 
> The Module to handle SSI's is loaded.

The most likely explanation is that your Options directive is not
applying to the relevant document because it is overriden elsewhere in
the config file.  See:
http://httpd.apache.org/docs/misc/FAQ.html#options

Also note that #include virtual should always be used in preference to
#exec cgi.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message