httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stanislas Renan <stanislas.remove-enlevez.re...@volcane.fr>
Subject [users@httpd] [win32][PHP] UNC path vs mapping
Date Fri, 02 Jul 2004 10:56:12 GMT
Hi,

I've got a strange behaviour with apache 2.0.49 running a PHP (4.3.7) 
script, and I don't know if it is a bug, and if it's a bug, if it is 
related to PHP or apache.

I use a virtual host, with a document root on a network drive (on a 
linux box, with samba).
If I configure the virtual host with a path like "z:/path", everything 
works fine BUT apache cannot run as a service, as the z: mapping is done 
  in the interactive session environment.
In this configuration, the PHP command "exec('cd')" outputs "z:\path".

Thus, I use the preferred UNC notation for my virtual host : 
"//host/share/path" . But if I do that, the PHP command "exec('cd')" 
outputs "c:\windows".

Therefore all my commands executed through exec() have a different 
behaviour depending on the notation of the DocumentRoot (there's also a 
Directory directive for the same location), even if, physically, it 
points to the same location.

I had to stop considering running apache as a service for this 
configuration (hopefully, it's only a development system).

So, is it a bug ? and if so, an apache one, or a PHP one ?
My opinion is that it is a bug, as it prevents me from running the 
application as a service in this network configuration.

Regards,
-- 
Stanislas Renan
http://www.volcane.fr/


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message