httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] Strange Errors on restart
Date Sat, 03 Jul 2004 09:08:45 GMT
On Fri, 2 Jul 2004, Webmaster wrote:

> Every time I do 'apachectl stop' then start, I see something like this
  in the httpd-error.log:
>
> [Fri Jul 02 23:16:04 2004] [notice] caught SIGTERM, shutting down
> [Fri Jul 02 23:16:08 2004] [notice] Apache/2.0.49 (FreeBSD) PHP/4.3.7 configured -- resuming
normal operations
> [Fri Jul 02 23:16:08 2004] [error] (13)Permission denied: Failed to child-init debuglog
mutex
> [Fri Jul 02 23:16:08 2004] [error] (13)Permission denied: Failed to child-init auditlog
mutex

I don't believe any of those messages come from apache, which leads me to
suppose it's some buggy third-party module - either PHP or some other that
didn't advertise itself.

The message seems pretty clear though: something has made a mess of
setting up a mutex.  That's a two-stage process; child-init is the second
part.  I suggest you try identifying suspects, and remove each in turn
until you identify the culprit.

-- 
Nick Kew

Nick's manifesto: http://www.htmlhelp.com/~nick/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message