httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Cameron <ke...@kevincameron.net>
Subject [users@httpd] Memory limits?
Date Sat, 10 Jul 2004 12:20:42 GMT
Hi I have been using Apache 1.3 with RedHat 7.2 for a while now, but am 
upgrading to RedHat ES with Apache 2.0 (actually the 
httpd-2.0.46-32.ent rpm that comes with RedHat ES).

I have found however that several CGI programs (all perl) which used to 
work fine no longer work durring certain routines. They simply hang and 
eventually time out. I have tracked the problem in some of the CGIs to 
find that if I cut out a certain line or loop that I presume uses more 
memory or time to execute than some other line, the program will go 
though to completion.  Likewise, on very simple pages, there is no 
problem executing the script until completion.

I am not receiving any errors, and I have apache configured the same as 
on the previous servers. I do not see any increase in memory usage with 
top either. The process simply hangs and times out.

Is there such a setting that is restricting my per-proccess memory 
usage? I have searched and searched for any clue, but can't find 
anyhting.

I am not certain if this is even an apache issue, but if it is, or if 
someone has experienced the same thing, I would appreciate some help.

Thanks
Kevin


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message