httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Villa" <jvi...@e37.net>
Subject [users@httpd] Can't find mod_ssl in Apache2
Date Sun, 11 Jul 2004 21:01:10 GMT
 Quoting from a book I'm reading

"In Apache 2.0, mod_ssl has the status of a standar Apache module,....will
not be compiled into the Apache server unless you enable it explicitly
with the --enable-module switch".

So, this is how I configured Apache 2.0.49

./configure --enable-cgi --enable-module=so --prefix=/usr/local/apache
--enable-ssl

and also tried

./configure --enable-cgi --enable-module=so --prefix=/usr/local/apache
--enable-ssl --with-ssl=/usr/include/openssl

Apache is fine on port 80, runs great, however when I try port 443 I have
issues.

On Mozilla I get the error:

Could not establish an encrypted connection because certificate provided
by mydomain.com is invalid or corrupted. Error code: -8182

After doing some googling, people seem to relate this to a Mozilla issue.

So I tried IE (running under wine) and Konqueror, those browsers just give
me a 404.

Error log says nothing, I'm checking the default VH error log.  When I
restart Apache I get

[Sun Jul 11 15:50:05 2004] [notice] Apache/2.0.49 (Unix) mod_ssl/2.0.49
OpenSSL/0.9.7a PHP/4.3.6 configured -- resuming normal operations

Now, as to the subject of this post, the book I'm reading, as well as
making the best informed guess I can, says to look for

<IfDefine SSL>
LoadModule ssl_module modules/mod_ssl.so
</IfDefine>

There is no mod_ssl.so @ at all on my system.  I've updated locate as well
as did a find and can't find anything.  When I start httpd I'm asked for
my  passphrase, enter it and get a success message...

Any ideas?




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message