httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian V Hughes <bria...@Dartmouth.EDU>
Subject [users@httpd] Installing 2.0.50 on OS X 10.3 (Panther)
Date Thu, 08 Jul 2004 19:08:56 GMT

Hello list! After getting assistance from Joshua and André last week, 
I've endeavored to upgrade to the 2.0.50 release. I'm not sure if the 
problem I'm having is actually specific to OS X 10.3, but that's the 
environment I'm installing under. Here's what I'm doing:

I've downloaded and unpacked the 2.0.50 sources,
Ran buildconf, because I saw somewhere that that was a good idea under 
OS X (darwin)
This is an install to take the place of an existing 2.0.48 install, 
which contained the following config.nice script:

#! /bin/sh
#
# Created by configure

"./configure" \
"--prefix=/Library/Apache2" \
"--exec-prefix=/Library/Apache2/bin" \
"--enable-layout=ServLog" \
"--enable-so" \
"--enable-mods-shared=all" \
"--with-ssl=/usr" \
"--with-mpm=prefork" \
"--enable-ssl" \
"--enable-dav" \
"--enable-cache" \
"--enable-proxy" \
"--enable-shared" \
"--disable-static" \
"--disable-unique-id" \
"--disable-ipv6" \
"--with-ldap" \
"--enable-auth-ldap" \
"--with-z=/usr" \
"--enable-logio" \
"--enable-suexec" \
"--enable-deflate" \
"$@"

I'm not necessarily tied to all of these options (I don't even know 
what the --with-mpm=prefork is for :), but they seemed to work pretty 
well in the 2.0.48 install that I already had working, courtesy of 
Complete Apache2 from Server Logistics (great package, btw), and I 
wanted to match that as close as I could. I added in the --prefix and 
--exec-prefix lines to match the location of the existing install.

Using this config set-up seems to work really well.
I run make and it compiles everything without a hitch.
I run "sudo make install" and get this error:

/bin/sh /Users/webmaster/Applications/httpd-2.0.50/srclib/apr/libtool 
--mode=install cp apr.exp /Library/Apache2/bin/lib
cp apr.exp /Library/Apache2/bin/lib/apr.exp
if [ ! -d  ]; then \
         
/Users/webmaster/Applications/httpd-2.0.50/srclib/apr/build/mkdir.sh ; 
\
fi;
if [ -f libtool ]; then \
         /bin/sh 
/Users/webmaster/Applications/httpd-2.0.50/srclib/apr/libtool 
--mode=install cp libtool ; \
fi;
libtool: install: you must specify a destination
Try `libtool --help --mode=install' for more information.
make[2]: *** [install] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1

Can someone tell me why there's no argment for the "if [! -d ]" 
statement? That certainly appears to be the reason the subsequent "cp 
libtool" command fails.

I thought the problem might be the fact that the existing 2.0.48 was 
still in place, so I re-did the build process after renaming the 
/Library/Apache2 folder. Still existed make install at the same 
location.

Thanks. And let me know if you need to see more info from configure, 
make or make install outputs. I'm happy to provide.

-Brian
----
Brian V. Hughes
Associate Director for Web Operations
Computing Technical Services
Dartmouth College
http://www.dartmouth.edu/~tech/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message