httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Stoll <technow...@gmx.de>
Subject [users@httpd] Alltimer mod_rewrite
Date Tue, 20 Jul 2004 12:31:00 GMT
Hello Listmembers,

I´m a bit stuck in fiddling my rewrite rules...

What I want to do:

For hosting several Typo3 sites several working vhosts are present, I´d 
like the backend via SSL so I map the backends of the vhosts to 
directory of one SSL vhost via a redirect in each vhost. So far so good, 
this is working fine, but when a preview of the frontend page is 
requested I need to rewrite the request back to the normal vhost...

in ssl.conf :

Alias /typo3ssl-site1 /vhosts/www.site1.de/webroot/typo3
# alias for backend directory of normal vhost to directory on SSL vhost

RewriteEngine   on
RewriteLog      /root/rlog
RewriteLogLevel 9
RewriteCond    %{HTTP_REFERER} !^$
RewriteCond    %{HTTP_REFERER} 
^/typo3ssl-site1/ext/viewpage/view/frameset.php.*
RewriteRule    ^index.php(.*)$ http://www.site1.de/$1   [R]

<Directory /vhosts/www.site1.de/webroot/typo3>
RewriteBase /typo3ssl-site1
</Directory>

my referer is :
https://sslhost.server.de/typo3ssl-site1/ext/viewpage/view/frameset.php?&id=0

which requested:
https://sslhost.server.de/index.php?id=0

but this needs to be:
http://www.site1.de/index.php?id=0

the rewrite log is empty, nothing in there...

Maybe someone can point me to the proper solution...

Regards, AS


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message