httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yan Zhou <yzh...@yahoo.com>
Subject [users@httpd] Q: run MPM worker in a single process model
Date Thu, 29 Jul 2004 17:39:37 GMT
Hi,

My app. server recommends Apache2 to run as single process model. I have
compiled MPM worker but could not get it working in single process,
multi-thread model.

I have tried setting ServerLimits and StartUpServer both to 1, I still have
three httpd processes, one is the control process and the other two are the
worker processes. But I only want one worker process, i.e., single process
model. In addition, no matter what I set to StartUpServers, I always get two
httpd child processes running.

The configure file and compiler options are all correct, as changes in other
configure parameters take effect, and httpd -l shows worker.c. I even
debugged Apache and all the values are read in correctly. Except for not
running as a single process, Apache functions well.

I also tried switching to MPM perchild and set NumServers to 1, had the same
situation, still got two child processes running.

What did I miss and how can I debug this?
Thanks.
Yan



		
__________________________________
Do you Yahoo!?
Yahoo! Mail is new and improved - Check it out!
http://promotions.yahoo.com/new_mail

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message